Maybe old habits should die…

Eventually I found myself without an LTM lens…which meant I couldn’t shoot the Canon IVSb.

There is something very “Little House on the Prairie” about shooting that camera–Even though I never liked the show, I found myself drawn back to the whole experience.  (It seemed a shame to let it sit there without a lens…especially since Youxin had CLA’d it and changed the shutter curtains).

Therefore, after a little bit of research, I found a Canon 50mm f/1.4 LTM lens which I ordered from E-bay.  As luck would have it, it arrived at exactly the same time as an off-brand LTM adapter (K&F Concept) that I had also ordered.

Unfortunately, with the crappy adapter, the lens was out at infinity on the M9 and MP.

Undeterred, I threw it on the Canon, and got to shooting.

This is Rollei Retro 400S (which I have never shot before) pushed to ISO 800 (which apparently no one has EVER done, as I had to make up times…) and developed in D76.

The first thing I noticed, was how DIM and finicky the IVSb rangefinder seemed.    (Why do I even LIKE shooting with it??)  The first five photos were taken with that particular setup.  Mid-roll, I just couldn’t take it any more, and loaded the half-finished roll into the MP instead.  Despite the poor quality adapter, results seemed reasonable–even at f/1.4.

Anyway, I kind of like the rendering of the lens, so now I’m sort of torn at what to do (the aperture and focus rings are rather stiff, despite the perfect glass…) Have it CLA’d?  Buy a new adapter?

Regardless, it seems as though the IVSb should probably be left for what it is:  An intriguing historical relic who’s time has probably passed…

Just like my eyesight.